Fabric |
Sets the major layout pattern as MaximumSpacing, while specifying the needed parameters for this pattern.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SetMinorLayoutAsMaximumSpacing(
double overallLength,
double majorStartOverhang,
double majorEndOverhang,
double spacing
)
Parameters
- overallLength Double
- The entire length of the wire sheet in the major direction.
- majorStartOverhang Double
- The distance from the edge of the sheet to the first wire in the major direction.
- majorEndOverhang Double
- The distance from the last wire to the edge of the sheet in the major direction.
- spacing Double
- The distance between the wires in the minor direction.

Exception | Condition |
---|---|
ArgumentException | The given value for overallLength is not a number -or- The given value for majorStartOverhang is not a number -or- The given value for majorEndOverhang is not a number -or- The given value for spacing is not a number -or- The arguments are not consistent, please specify proper input values. |
ArgumentOutOfRangeException | The given value for overallLength must be greater than 0 and no more than 30000 feet. -or- The given value for majorStartOverhang must be between 0 and 30000 feet. -or- The given value for majorEndOverhang must be between 0 and 30000 feet. -or- The given value for spacing must be greater than 0 and no more than 30000 feet. |