Link Method (String, DWGImportOptions, View, ElementId)


Document Link(String, DWGImport Options, View, Element Id ) Method

Links a DWG or DXF file into the project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool Link(
	string file,
	DWGImportOptions options,
	View pDBView,
	out ElementId elementId
)

Parameters

file String
Full path of the file to link. File must exist and must be a valid DWG or DXF file.
options DWGImportOptions
Various import options applicable to the DWG or DXF format. If , all options will be set to their respective default values.
pDBView View
View used to aid placement of the linked file. If the options specify ThisViewOnly, this argument is required and the linked file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the linked file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the linked file. If not specified, an existing view will be chosen instead and may open a view or associate the linked file to an arbitrary level.
elementId ElementId
The id of linked instance after a successful link.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception Condition
ArgumentException Not a valid file for DWG import (.dwg and .dxf files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The line weights are not valid; either it contains an invalid number of line weights, or a line weight outside the valid range. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
ArgumentNullException A non-optional argument was null
FileArgumentNotFoundException The given file does not exist.
InvalidOperationException Import is temporarily disabled. -or- This Document is not a project document.
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
OptionalFunctionalityNotAvailableException The DWG Import/Link module is not available in the installed Revit.
Remarks
Link isn't supported for family documents. Please use import instead.
See Also