View Get |
Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

Parameters
- linkId ElementId
- The id of the RevitLinkType or RevitLinkInstance .
Return Value
RevitLinkGraphicsSettingsSettings representing graphic overrides for the input element id in the view, or if the input id references RevitLinkInstance and it doesn't have overrides in the view.

Exception | Condition |
---|---|
ArgumentException | The input id is not a valid RevitLinkInstance or RevitLinkType id. |
ArgumentNullException | A non-optional argument was null |