IsMain Method


MEPSection Is Main Method

Check whether the type of fitting in this section is main.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsMain(
	ElementId fittingId
)

Parameters

fittingId ElementId
The element id which can be duct fitting and pipe fitting.

Return Value

Boolean
True if the type of fitting in this section is main False if the type of fitting in this section is branch
Exceptions
Exception Condition
ArgumentException The ElementId fittingId does not correspond to a valid section fitting member.
ArgumentNullException A non-optional argument was null
See Also