GetExportId Method


Export Utils Get Export Id(Document, Element Id) Method

Retrieves the GUID representing this element in DWF and IFC export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Guid GetExportId(
	Document document,
	ElementId elementId
)

Parameters

document Document
The document.
elementId ElementId
The id of the element.

Return Value

Guid
The value of the GUID representing the element in the export context.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
This id is used in the contents of DWF export and IFC export and it should be used only when cross-referencing to the contents of these export formats. When storing Ids that will need to be mapped back to elements in future sessions, UniqueId must be used.
See Also