Paint Method (ElementId, Face, FamilyParameter)


Document Paint(Element Id, Face, Family Parameter) Method

Paint the element's face with specified material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void Paint(
	ElementId elementId,
	Face face,
	FamilyParameter familyParameter
)

Parameters

elementId ElementId
The element that the face belongs to.
face Face
The painted element's face.
familyParameter FamilyParameter
The family parameter associated with a material.
Exceptions
Exception Condition
ArgumentException The element elementId does not exist in the document. -or- The element materialId does not exist in the document. -or- The face doesn't belongs to the element. -or- The family parameter doesn't specify a material element. -or- The element's face cannot be painted.
ArgumentNullException A non-optional argument was NULL
InvalidOperationException This document is not modifiable. -or- This operation is valid only in family.
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
See Also