Spatial |
Constructs a new calculator for the geometry of spatial elements.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public SpatialElementGeometryCalculator(
Document aDoc,
SpatialElementBoundaryOptions options
)
Parameters
- aDoc Document
- The document that contains the spatial elements.
- options SpatialElementBoundaryOptions
- The options to control the calculation rules.

Exception | Condition |
---|---|
ArgumentException | options is not valid. Only Finish and Center of SpatialElementBoundaryLocation are allowed. |
ArgumentNullException | A non-optional argument was null |