ReloadLatest Method


Document Reload Latest Method

Fetches changes from central (due to one or more synchronizations with central) and merges them into the current session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void ReloadLatest(
	ReloadLatestOptions reloadOptions
)

Parameters

reloadOptions ReloadLatestOptions
Various options to control behavior of reloadLatest.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
CentralFileCommunicationException The file-based central model could not be reached, because e.g. the network is down or the file server is down.
CentralModelAccessDeniedException Access to the central model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException The central model is locked by another client.
CentralModelException Username does not match the one used to create the local file. -or- Revit could not save all of the worksets that have been changed. Try again. -or- The central model has been replaced by a local model. -or- Local incompatible because it was closed without saving after synchronizing with central. -or- The central model is missing. -or- The central model is incompatible. -or- The central model is corrupt or not an RVT file. -or- The central model was rolled back. -or- The central model's elements have been relinquished -or- The central model is overritten by other user. -or- An internal error happened on the central model, please contact the server administrator.
FileNotFoundException Cannot access the local file.
InvalidOperationException This Document is not a primary document, it is a linked document. -or- This Document is not a local model: it is not workshared or is central. -or- This Document is read-only: It cannot be modified. -or- This Document has an open editing transaction and is accepting changes. -or- This Document is not a project document. -or- This Document is in an edit mode. -or- This Document is a local file that is not owned by the current user, who therefore is not allowed to modify it. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group.
OperationCanceledException Reload Latest was canceled by the user or by an API event callback.
RevitServerCommunicationException The server-based central model could not be accessed because of a network communication error.
RevitServerInternalException An internal error happened on the server, please contact the server administrator.
RevitServerUnauthenticatedUserException User is not signed in with Autodesk id.
RevitServerUnauthorizedException User is not authorized to access the specified A360 project.
Remarks
After this call finishes, use hasAllChangesFromCentral to confirm that there were no Synchronizations with Central performed during execution of ReloadLatest.
See Also