ExcessLengthFillBalusterId Property


Baluster Pattern Excess Length Fill Baluster Id Property

The id of a Baluster family used to fill excess length, which is the extra space along the railing segment that cannot be filled with a pattern. If set to InvalidElementId, it will be the default - the id of the BaseRailingAttr containing the Baluster pattern.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId ExcessLengthFillBalusterId { get; set; }

Property Value

ElementId
Exceptions
Exception Condition
ArgumentException When setting this property: Invalid ElementId for leftoverFill of BalusterPattern
ArgumentNullException When setting this property: A non-optional argument was null
See Also