GetHCurveNormalAtStation Method


Alignment Get HCurve Normal At Station Method

Calculate 2d (X and Y components of returned vector) horizontal normal at given station.

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ GetHCurveNormalAtStation(
	double station
)

Parameters

station Double
Alignment station to calculate 2d horizontal normal for, in Revit internal model units (standard Imperial feet).

Return Value

XYZ
2d (X and Y components of returned vector) horizontal normal at given station.
See Also