IntegerValue Property


Element Id Integer Value Property

Note: This API is now obsolete.

Provides the value of the element id as a 32-bit integer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
[ObsoleteAttribute("This property is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the Value property instead.")]
public int IntegerValue { get; }

Property Value

Int32
Exceptions
Exception Condition
InvalidOperationException Thrown when the value of the element id is too large to be represented as a 32-bit integer.
See Also