StructuralElementDefinitionData Class


Structural Element Definition Data Class

Class containing information about section and position of the structural element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure.StructuralSections StructuralElementDefinitionData

Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class StructuralElementDefinitionData : IDisposable

The StructuralElementDefinitionData type exposes the following members.

Constructors
Name Description
Public method StructuralElementDefinitionData Creates empty StructuralElementDefinitionData object.
Top
Properties
Name Description
Public property CenterCurve The curve lying in the geometrical center of the element.
Public property Curve The definition curve of the element.
Public property EndShortening Cutback or extension at element curve end.
Public property IsMirrored States if the structural section of the element is mirrored.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Normal The local Z direction of the element section in the start point of the curve.
Public property Section Structural section of the element.
Public property StartShortening Cutback or extension at element curve start.
Public property YJust Y justification (ref axis).
Public property YOffset Y offset.
Public property ZJust Z justification (ref axis).
Public property ZOffset Z offset.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the StructuralElementDefinitionData
Top
See Also