MechanicalUtils Class


Mechanical Utils Class

General utility methods in the Autodesk Revit MEP product.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Mechanical MechanicalUtils

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class MechanicalUtils

The MechanicalUtils type exposes the following members.

Methods
Name Description
Public method Static member BreakCurve Breaks the duct curve into two parts at the given position.
Public method Static member ConnectAirTerminalOnDuct Connects an air terminal to a duct directly (without the need for a tee or takeoff).
Public method Static member ConnectDuctPlaceholdersAtCross(Document, ElementId, ElementId) Connects a pair of placeholders that can intersect in a Cross connection.
Public method Static member ConnectDuctPlaceholdersAtCross(Document, ElementId, ElementId, ElementId) Connects a trio of placeholders that can intersect in a Cross connection.
Public method Static member ConnectDuctPlaceholdersAtCross(Document, Connector, Connector, Connector, Connector) Connects a group of placeholders that can intersect in a Cross connection.
Public method Static member ConnectDuctPlaceholdersAtElbow(Document, Connector, Connector) Connects a pair of placeholders that can intersect in an Elbow connection.
Public method Static member ConnectDuctPlaceholdersAtElbow(Document, ElementId, ElementId) Connects a pair of placeholders that can intersect in an Elbow connection.
Public method Static member ConnectDuctPlaceholdersAtTee(Document, ElementId, ElementId) Connects a pair of placeholders that can intersect in a Tee connection.
Public method Static member ConnectDuctPlaceholdersAtTee(Document, Connector, Connector, Connector) Connects a trio of placeholders that can intersect in a Tee connection.
Public method Static member ConvertDuctPlaceholders
Top
See Also