Structural |
Return structural element definition data.
Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static StructuralSectionErrorCode GetStructuralElementDefinitionData(
Document document,
ElementId elementId,
out StructuralElementDefinitionData data
)
Parameters
- document Document
- The document that owns the beam, brace or structural column.
- elementId ElementId
- ID of family instance for beam, brace or structural column.
- data StructuralElementDefinitionData
- Structural element definition data.
Return Value
StructuralSectionErrorCodeSuccess code is returned if StructuralElementDefinitionData was provided successfully, error code otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

This information is provided only for beams, braces and structural columns.