Wall Get |
Gets an array of references to faces at the location.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- locationIndex Int32
- 0 or 1 represents wall's end, other number represents the wrapping locations on vertical faces of openings or profiles.
Return Value
IList ReferenceAll faces' references at the location.

Exception | Condition |
---|---|
ArgumentException | This location is invalid for wrapping. |

If the location is invalid, for example: wall doesn't have this location or the location is joined, this function throws ArgumentException. This function may return not only one face, for example: after editing profile, some aligned vertical faces have same location on curve.