MaterialId Property


Stairs Run Type Material Id Property

The material of the stairs run, only available for monolithic stairs run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId MaterialId { get; set; }

Property Value

ElementId
The id of the material of the stairs run, invalid ElementId if the stairs run is not monolithic.
Exceptions
Exception Condition
ArgumentException When setting this property: The materialId is not a valid material element.
ArgumentNullException When setting this property: A non-optional argument was null
InvalidOperationException When setting this property: The stairs run type is not a monolithic type so the data being set is not applicable.
See Also