IsProductListEntryCompatibleSize Method


Fabrication Part Is Product List Entry Compatible Size Method

Checks to see if this part can be changed to the specified product entry without altering any connected dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsProductListEntryCompatibleSize(
	int productEntry
)

Parameters

productEntry Int32
The product entry index.

Return Value

Boolean
Returns true if the part can be changed to the specified product entry without altering any connected dimensions.
Exceptions
Exception Condition
ArgumentOutOfRangeException The product entry index is not larger than 0 and less than GetProductCount.
See Also