Save |
This class contains options available for saving a document to disk with a new filename.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The SaveAsOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | SaveAsOptions | Default constructor. |

Name | Description | |
---|---|---|
![]() | Compact | Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | MaximumBackups | The maximum number of backups to keep on disk. |
![]() | OverwriteExistingFile | Identifies if the operation should be able to overwrite an existing file. |
![]() | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the SaveAsOptions |
![]() | GetWorksharingOptions | Gets Worksharing options for SaveAs. |
![]() | SetWorksharingOptions | Sets Worksharing options for SaveAs. |