AddReferencePoint Method (XYZ, DirectShapeReferenceOptions)


Direct Shape Type Add Reference Point(XYZ, Direct Shape Reference Options) Method

Adds a reference point to the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddReferencePoint(
	XYZ refPoint,
	DirectShapeReferenceOptions options
)

Parameters

refPoint XYZ
The coordinates of the new reference point.
options DirectShapeReferenceOptions
The options that are used to configure the new reference point.
Exceptions
Exception Condition
ArgumentException The input point lies outside of Revit design limits. -or- options cannot be used to add a reference object to this DirectShapeType.
ArgumentNullException A non-optional argument was null
See Also