LayoutRuleMaximumSpacing Class


Layout Rule Maximum Spacing Class

This class indicate the layout rule of a Beam System is Max-Spacing.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB LayoutRule
Autodesk.Revit.DB LayoutRuleMaximumSpacing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LayoutRuleMaximumSpacing : LayoutRule

The LayoutRuleMaximumSpacing type exposes the following members.

Constructors
Name Description
Public method LayoutRuleMaximumSpacing Constructor of LayoutRuleMaximumSpacing.
Top
Properties
Name Description
Public property IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Spacing Get or set the spacing of the beam system.
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
To use this type of LayoutRule, only the maximum spacing must be set and it must be in (0, 30000).
See Also