LayoutRuleMaximumSpacing Class


Layout Rule Maximum Spacing Class

This class indicate the layout rule of a Beam System is Max-Spacing.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB LayoutRule
Autodesk.Revit.DB LayoutRuleMaximumSpacing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LayoutRuleMaximumSpacing : LayoutRule

The LayoutRuleMaximumSpacing type exposes the following members.

Constructors
Name Description
Public method LayoutRuleMaximumSpacing Constructor of LayoutRuleMaximumSpacing.
Top
Properties
Name Description
Public property Spacing Get or set the spacing of the beam system.
Top
Methods
Name Description
Top
Remarks
To use this type of LayoutRule, only the maximum spacing must be set and it must be in (0, 30000).
See Also