ConvertToProjectTime Method


Site Location Convert To Project Time Method

Converts local time or UTC time to project time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public DateTime ConvertToProjectTime(
	DateTime inputTime
)

Parameters

inputTime DateTime
The input local time or UTC time.

Return Value

DateTime
Exceptions
Exception Condition
ArgumentException Thrown when the inputTime's kind is neither Local nor Utc.
Remarks
Daylight savings time is not considered during this conversion.
See Also