Family |
Provides access to the visibility parameters of family elements in family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The FamilyElementVisibility type exposes the following members.

Name | Description | |
---|---|---|
![]() | FamilyElementVisibility | Initializes a new instance of the FamilyElementVisibility class |

Name | Description | |
---|---|---|
![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |
![]() | IsShownInCoarse | Indicates if the instance is display with Coarse detail level in the view of project document. |
![]() | IsShownInFine | Indicates if the instance is display with Fine detail level in the view of project document. |
![]() | IsShownInFrontBack | Indicates if the instance is display in Front/Back view of project document. |
![]() | IsShownInLeftRight | Indicates if the instance is display in Left/Right view of project document. |
![]() | IsShownInMedium | Indicates if the instance is display with Medium detail level in the view of project document. |
![]() | IsShownInPlanRCPCut | Indicates if the instance is displayed when cut in Plan/RCP (if the category permits). |
![]() | IsShownInTopBottom | Indicates if the instance is display in Plan/RCP view of project document. |
![]() | IsShownOnlyWhenCut | Indicates if the instance is displayed only if it has been cut. |
![]() | VisibilityType | Indicates if the instance is Model or View specific. |

Name | Description | |
---|---|---|
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |