FBXExportOptions Class


FBXExport Options Class

3D-Studio Max (FBX) Export options.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FBXExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FBXExportOptions

The FBXExportOptions type exposes the following members.

Constructors
Name Description
Public method FBXExportOptions Default constructor. Sets all options to their default values.
Top
Properties
Name Description
Public property LevelsOfDetailValue The value of the levels of detail.
Public property StopOnError Whether export process should stop when a view fails to export.
Public property UseLevelsOfDetail True to use levels of detail, false otherwise.
Public property WithoutBoundaryEdges True to export without boundary edges, false otherwise.
Top
Methods
Name Description
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also