ActivateControlsAndDimensionsOnMultiSelect Property


Selection UIOptions Activate Controls And Dimensions On Multi Select Property

Indicates whether controls and temporary dimensions are activated on selection of multiple elements.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool ActivateControlsAndDimensionsOnMultiSelect { get; set; }

Property Value

Boolean
Remarks
Revit always shows certain controls and temporary dimensions for a single selected element When this option is set Revit also shows these controls and dimensions when multiple elements are selected. Note that this setting takes effect on the next selection change. To have this change take effect immediately use
C#
Selection.SetElementIds(Selection.GetElementIds());
See Also