IPoint |
An interface that Revit will call when iterating through sets of points on the engine.
Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The IPointSetIterator type exposes the following members.

Name | Description | |
---|---|---|
![]() | Free | Use this method to discard any resources consumed by the iterator. Revit will call it when done using the iterator. |
![]() | ReadPoints | Implement this method to fill the provided buffer with points up to the number of maximum points for which the buffer was allocated. |

An instance of this interface is obtained from the Point Cloud engine when the engine's CreatePointSetIterator method is called.