DWGImport |
The import options used by importing DWG or DXF format file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The DWGImportOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | DWGImportOptions | Constructs a new instance of DWGImportOptions with default values of all properties. |
![]() | DWGImportOptions(DWGImportOptions) | Constructs a new instance of DWGImportOptions as a copy of the import options. |

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() | GetLineWeights | Gets array of line weights. |
![]() | SetLineWeights | |