DWGImport |
The import options used by importing DWG or DXF format file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The DWGImportOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | DWGImportOptions | Constructs a new instance of DWGImportOptions with default values of all properties. |
![]() | DWGImportOptions(DWGImportOptions) | Constructs a new instance of DWGImportOptions as a copy of the import options. |

Name | Description | |
---|---|---|
![]() | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions ) |
![]() | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions ) |
![]() | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions ) |
![]() | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions ) |
![]() | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions ) |
![]() | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions ) |
![]() | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions ) |
![]() | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions ) |
![]() | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from BaseImportOptions ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions ) |
![]() | GetLineWeights | Gets array of line weights. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions ) |
![]() | SetLayerSelection | (Inherited from BaseImportOptions ) |
![]() | SetLineWeights | |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |