VectorAtPoint Class


Vector At Point Class

Stores vectors at one domain point. Each vector corresponds to a "measurement" for which this vector was calculated.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ValueAtPointBase
Autodesk.Revit.DB.Analysis VectorAtPoint

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class VectorAtPoint : ValueAtPointBase

The VectorAtPoint type exposes the following members.

Constructors
Name Description
Public method VectorAtPoint(IList XYZ ) Initializes a new instance of the VectorAtPoint class
Public method VectorAtPoint(VectorAtPoint) Creates a copy of the given VectorAtPoint instance.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ValueAtPointBase )
Top
Methods
Name Description
Public method ClearAllFlags Sets flags for all measurements to ValueAtPointFlags::None.
(Inherited from ValueAtPointBase )
Public method ClearFlagsAt Sets flags for the given measurement to ValueAtPointFlags::None.
(Inherited from ValueAtPointBase )
Public method Dispose
(Inherited from ValueAtPointBase )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetFlags Returns flags for the given measurement.
(Inherited from ValueAtPointBase )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetFlags(IList Int32 )
(Inherited from ValueAtPointBase )
Public method SetFlags(Int32) Sets the flags associated to all measurements to the same value.
(Inherited from ValueAtPointBase )
Public method SetFlags(Int32, Int32) Sets the flags associated to a given measurement.
(Inherited from ValueAtPointBase )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also