GetFailureDefinitionId Method


Failure Message Accessor Get Failure Definition Id Method

Retrieves the Id of the FailureDefinition of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FailureDefinitionId GetFailureDefinitionId()

Return Value

FailureDefinitionId
The Id of the FailureDefinition of the failure.
Exceptions
Exception Condition
InvalidOperationException This FailureMessageAccessor has not been properly initialized.
See Also