AppendVertex Method


Wire Append Vertex Method

Appends one vertex to the end of the wire.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AppendVertex(
	XYZ vertexPoint
)

Parameters

vertexPoint XYZ
The vertex to be appended.
Exceptions
Exception Condition
ArgumentException The vertex point cannot be added to the wire because there is already a vertex at this position on the view plane (within tolerance).
ArgumentNullException A non-optional argument was null
InvalidOperationException The end point is already connected to an element, so a new endpoint vertex cannot be appended.
See Also