Parameter |
Retrieves settings associated with the given parameter from the Parameters Service.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ParameterDownloadOptions DownloadParameterOptions(
ForgeTypeId parameterTypeId
)
Parameters
- parameterTypeId ForgeTypeId
- Parameter identifier.
Return Value
ParameterDownloadOptionsSettings associated with a parameter.

Exception | Condition |
---|---|
AccessDeniedException | Thrown when the user is not authorized to access the requested information. |
ArgumentException | Thrown when the given parameter identifier is empty. |
ArgumentNullException | A non-optional argument was null |
[!:Autodesk::Revit::Exceptions::NetworkCommunicationError] | Thrown when communication with the Parameters Service is unsuccessful. |
ResourceNotFoundException | Thrown when the requested parameter is not found. |
ServerInternalException | Thrown when the Parameters Service reports an internal error. |
UnauthenticatedException | Thrown when the user is not signed in. |

The settings associated with a parameter definition are accessible only to an authorized user. To retrieve them, the user must be signed in.