SetStaggerLength Method


Rebar Bar Type Set Stagger Length Method

Sets the stagger length for the specified Rebar Splice Type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetStaggerLength(
	ElementId rebarSpliceTypeId,
	double staggerLength
)

Parameters

rebarSpliceTypeId ElementId
The Rebar Splice Type id. Interactions with Rebar Splice Types can be done with the functions in RebarSpliceTypeUtils .
staggerLength Double
The new value of the stagger length.
Exceptions
Exception Condition
ArgumentException The rebarSpliceTypeId doesn't represent a valid Rebar Splice Type. It should be an ElementType of BuiltInCategory.OST_RebarSpliceType category. -or- For the specified Rebar Splice Type the stagger length is auto calculated and the stagger length cannot be manually set. Its value is computed based on the formula splice type: stagger length multiplier * bar nominal diameter.
ArgumentNullException A non-optional argument was null
See Also