GetStatus Method


Transaction Get Status Method

Returns the current status of the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public TransactionStatus GetStatus()

Return Value

TransactionStatus
The current status of the transaction.
Remarks
If the status was set to TransactionStatus.Pending as the result of calling Commit or RollBack, the status will be changed later to either 'Committed' or 'RolledBack' after failure handling is finished. That status change will be made asynchronously.
See Also