SetPhase Method


Revit Link Graphics Settings Set Phase Method

Sets phase id and phase type of RevitLinkGraphicsSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetPhase(
	LinkVisibility phaseType,
	ElementId phaseId
)

Parameters

phaseType LinkVisibility
The type of the phase.
phaseId ElementId
The id of the phase from the linked document or InvalidElementId . If phaseType is set to ByHostView or ByLinkView the phaseId must be set to InvalidElementId . If phaseType is set to Custom and phaseId is InvalidElementId the phase will reference to the last phase from the linked document.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also