Analytical |
Creates a new instance of an Analytical Panel within the project.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
ArgumentException | One of the following requirements is not satisfied : - curve loop curveLoop is not planar - curve loop curveLoop is self-intersecting - curve loop curveLoop contains zero length curves |
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |

CurveLoop must be planar and not self-intersecting.