RebarUpdateCurvesData Class


Rebar Update Curves Data Class

Class holding the information needed to calculate the rebar curves.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarUpdateCurvesData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarUpdateCurvesData : IDisposable

The RebarUpdateCurvesData type exposes the following members.

Properties
Name Description
Public property AlignedFreeFormSetOrientationOptions Orientation options for an Aligned Free Form Rebar set.
Public property AreOrientationOptionsChanged Indicates if the orientation options have changed since the last regeneration.
Public property AreWorkshopInstructionsChanged Indicates if the workshop instructions have changed since the last regeneration.
Public property CycleCounterChanged

True if the cycle counter was changed, false otherwise.

The cycle counter value is changed when the free form Rebar element is selected and the user press Space key -or- by through [!:Autodesk::Revit::DB::Structure::RebarRebarFreeFormAccessor::CycleCounter] property. -or- by the server if it considers that the counter reaches the maximum value and reset it (set it to 0).

Public property ErrorMessage The reason for calculation failure. If the calculation fails, this message will be shown in an error, or warning if we are editing the constraints.
Public property HostMirrored If true, then host of the rebar was mirrorred (along with the rebar) before this regeneration.
Public property IsAttachmentTypeChanged Indicates if the attachment type has changed since the last regeneration.
Public property IsBarsNumberChanged Indicates if the bar number has changed since the last regeneration.
Public property IsBendingRadiusChanged Indicates if the bending radius has changed since the last regeneration.
Public property IsEndConstraintChanged Indicates if the end handle constraint has changed since the last regeneration.
Public property IsLayoutChanged Indicates if the layout has changed since the last regeneration.
Public property IsReversed Used to store the state of the bar refering to the direction of the bars. This is useful when using face intersection to calculate bars. After mirroring, curves created from intersecting faces may be reversed, so we use this to store the state and keep the rebar pointing in the correct direction.
Public property IsSpacingChanged Indicates if the spacing has changed since the last regeneration.
Public property IsStartConstraintChanged Indicates if the start handle constraint has changed since the last regeneration.
Public property IsStyleChanged Indicates if the style has changed since the last regeneration.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Spacing The spacing between the bars, according to the LayoutRule.
Public property WorkshopInstructions Identifies the workshop instructions of this rebar.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RebarUpdateCurvesData
Public method GetAttachmentType Returns attachment type for stirrups to be used in cover calculation.
Public method GetBarGeometry Returns the geometry for a bar at the specified index currently in the Rebar.
Public method GetBarModelDiameter Gets the model diameter of the Rebar.
Public method GetBarNominalDiameter Gets the nominal diameter of the Rebar.
Public method GetBarsNumber Gets the number of bars specified in the layout options. This is used to calculate the sets driven by bar number.
Public method GetBendingRadius Gets the current bending radius of the rebar.
Public method GetChangedCustomHandles Returns an array containing custom handles that were changed since the last regeneration. Array is empty if no handles were changed since the last regeneration.
Public method GetChangedSharedParameterGUIDs Returns an array containing the shared parameter GUIDs that were changed since the last regeneration. Array is empty if no shared params were changed since the last regeneration.
Public method GetCustomConstraints Gets all rebar constraints that are attached to custom handles for this rebar.
Public method GetCycleCounter Gets the cycle counter that is stored in the rebar.
Public method GetDocument Gets a reference to the current document.
Public method GetEndConstraint Gets the current constraint for the end handle of the Rebar.
Public method GetHookOrientationAngle Get the hook orientation angle at end that is currently in the rebar.
Public method GetHookPlaneNormalForBarIdx Returns the normal of plane in which the hook at end of bar with index barPositionIndex that is currently in Rebar.
Public method GetHostId Gets the id of the host structural for this rebar.
Public method GetLayoutRule Gets the layout rule for this bar.
Public method GetNumberOfBars Returns the number of bars currently in the rebar.
Public method GetRebarId Get the id of the Rebar element currently being calculated.
Public method GetRebarStyle Gets the style of the rebar.
Public method GetStartConstraint Gets the current constraint for the start handle of the Rebar.
Public method SetCycleCounter Sets the cycle counter to a specific value.
Public method SetHookOrientationAngle Set the hook orientation angle at end. This information is set to the rebar after the API execution is finished successfully.
Public method SetHookPlaneNormalForBarIdx Set the normal of plane in which the hook at end of bar with index barPositionIndex will stay. This information is set to the rebar after the API execution is finished successfully.
Top
See Also