DuctFittingAndAccessoryConnectorData Class


Duct Fitting And Accessory Connector Data Class

The input data used by external servers for calculation of the duct fitting and duct accessory coefficient.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Mechanical DuctFittingAndAccessoryConnectorData

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DuctFittingAndAccessoryConnectorData : IDisposable

The DuctFittingAndAccessoryConnectorData type exposes the following members.

Properties
Name Description
Public property Angle the angle of the fitting, Units:(rad).
Public property Diameter The connector diameter, Units:(ft).
Public property Flow The connector flow, Units:(ft³/s)
Public property FlowDirection the flow direction of this connector, In or Out.
Public property Height The connector height, Units:(ft).
Public property Index return the index of this connector
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LinkIndex the index of the connector which is linked with this connector
Public property Profile The connector profile.
Public property VelocityPressure The connector velocity pressure. Units: (kg/(ft·s²)).
Public property Width The connector width, Units:(ft).
Top
Methods
Name Description
Public method Dispose Releases all resources used by the DuctFittingAndAccessoryConnectorData
Public method GetCoordination Gets the coordination of the connector
Top
Remarks
width, height, diameter, flow, velocity pressure and connector index are input data for the calculation,
See Also