ConvertToIndependent Method


View Convert To Independent Method

Convert the dependent view to independent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void ConvertToIndependent()
Exceptions
Exception Condition
InvalidOperationException This view is not dependent.
Remarks
This method can be only applied to a dependent view. A dependent view can be created from another view using method View.Duplicate(ViewDuplicateOption.AsDependent). Dependent views have a valid primary view element ID that can be obtained via method View.GetPrimaryViewId(); Independent views have InvalidElementId as their primary view ID.
See Also