MoveSpaceToEquipment Method


Zone Equipment Move Space To Equipment Method

Moves the selected analytical spaces from the identified zone equipment to another target zone equipment.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void MoveSpaceToEquipment(
	Document document,
	ISet<ElementId> analyticalSpaceSet,
	ElementId originalZoneEquipmentId,
	ElementId targetZoneEquipmentId
)

Parameters

document Document
The document where the zone equipment and the analytical spaces exist.
analyticalSpaceSet ISet ElementId
The specified analytical spaces to move.
originalZoneEquipmentId ElementId
The original equipment where the analytical spaces will be removed. If passing invalidElementId, the existing zone equipment is not removed.
targetZoneEquipmentId ElementId
The target zone equipment where the analytical spaces will be associated. If passing invalidElementId, the analytical spaces will not be assigned to any new zone equipment.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also