RemoveSegment Method


Curtain Grid Line Remove Segment Method

Remove the segment specified by the input curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void RemoveSegment(
	Curve curve
)

Parameters

curve Curve
The curve used to locate the segment to be removed.
Exceptions
Exception Condition
InvalidOperationException Segment may not have been found in location indicated by curve.
Remarks
When a segment is removed, the neighboring two panels will be merged into one panel. This function will invoke regeneration.
See Also