ViewOrientation3D Class


View Orientation 3D Class

Container for the point and vectors which define View3D's orientation.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ViewOrientation3D

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ViewOrientation3D : IDisposable

The ViewOrientation3D type exposes the following members.

Constructors
Name Description
Public method ViewOrientation3D Constructs a new ViewOrientation3D using the input eye position, up and forward directions.
Top
Properties
Name Description
Public property EyePosition The eye position point
Public property ForwardDirection The forward direction vector
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property UpDirection The up direction vector
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ViewOrientation3D
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also