NewFamilyInstanceCreationData Method (FamilySymbol, IList(XYZ))


Application New Family Instance Creation Data(Family Symbol, IList XYZ ) Method

Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
	FamilySymbol symbol,
	IList<XYZ> adaptivePoints
)

Parameters

symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
adaptivePoints IList XYZ
The adaptive point location where the adaptive instance is to be placed.

Return Value

FamilyInstanceCreationData
See Also