CreateGreaterRule Method (ElementId, Double, Double)


Parameter Filter Rule Factory Create Greater Rule(Element Id, Double, Double) Method

Creates a filter rule that determines whether double-precision values from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static FilterRule CreateGreaterRule(
	ElementId parameter,
	double value,
	double epsilon
)

Parameters

parameter ElementId
A double-typed parameter used to get values from the document for a given element.
value Double
The user-supplied value against which values from the document will be compared.
epsilon Double
Defines the tolerance within which two values may be considered equal.

Return Value

FilterRule
Exceptions
Exception Condition
ArgumentException The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
ArgumentNullException A non-optional argument was null
Remarks
Values greater than value but within epsilon are considered equal, not greater.
See Also