GetControlPoints Method


Form Get Control Points Method

Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ReferenceArray GetControlPoints(
	Reference curveOrEdgeOrFaceReference
)

Parameters

curveOrEdgeOrFaceReference Reference
The reference of an edge or curve or face.

Return Value

ReferenceArray
Reference array containing all control points lying on it.
See Also