Application |
The exception that is thrown when a non-fatal application error occurs.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ApplicationException type exposes the following members.

Name | Description | |
---|---|---|
![]() | FunctionId | The information of the function throwing the exception. |

Name | Description | |
---|---|---|
![]() | GetObjectData | Retrieves data needed to serialize the target object. (Overrides Exception GetObjectData(SerializationInfo, StreamingContext) ) |

This class is the base class of all Revit specified exceptions.

Reference

System Object
System Exception
Autodesk.Revit.Exceptions ApplicationException
Autodesk.Revit.Exceptions AccessDeniedException
Autodesk.Revit.Exceptions ArgumentException
Autodesk.Revit.Exceptions BackgroundTaskCancelledException
Autodesk.Revit.Exceptions CentralModelException
Autodesk.Revit.Exceptions CorruptModelException
Autodesk.Revit.Exceptions ExternalApplicationException
Autodesk.Revit.Exceptions InternalException
Autodesk.Revit.Exceptions InvalidOperationException
Autodesk.Revit.Exceptions IOException
Autodesk.Revit.Exceptions NetworkCommunicationException
Autodesk.Revit.Exceptions OperationCanceledException
Autodesk.Revit.Exceptions ResourceNotFoundException
Autodesk.Revit.Exceptions RevitServerException
Autodesk.Revit.Exceptions ServerInternalException
Autodesk.Revit.Exceptions UnauthenticatedException
System Exception
Autodesk.Revit.Exceptions ApplicationException
Autodesk.Revit.Exceptions AccessDeniedException
Autodesk.Revit.Exceptions ArgumentException
Autodesk.Revit.Exceptions BackgroundTaskCancelledException
Autodesk.Revit.Exceptions CentralModelException
Autodesk.Revit.Exceptions CorruptModelException
Autodesk.Revit.Exceptions ExternalApplicationException
Autodesk.Revit.Exceptions InternalException
Autodesk.Revit.Exceptions InvalidOperationException
Autodesk.Revit.Exceptions IOException
Autodesk.Revit.Exceptions NetworkCommunicationException
Autodesk.Revit.Exceptions OperationCanceledException
Autodesk.Revit.Exceptions ResourceNotFoundException
Autodesk.Revit.Exceptions RevitServerException
Autodesk.Revit.Exceptions ServerInternalException
Autodesk.Revit.Exceptions UnauthenticatedException