Revit |
Moves this link instance so that the base point in the linked document is aligned to the base point in the host document. This is a one-time movement and does not set up any shared coordinates relationship.
If the rotation angle of this link instance was changed after insertion, the rotation angle can be preserved or reset to the original insertion angle.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- resetToOriginalRotation Boolean
-
Sets to true if:
- restoring the original insertion angle of the link instance after it is moved if there was a rotation \ mirror transform on the link instance.
- there was no a rotation \ mirror transform on the link instance.
Sets to false to retain the current angle of the link instance after it is moved if there was a rotation \ mirror transform on the link instance.

Exception | Condition |
---|---|
InvalidOperationException | This RevitLinkInstance is not an instance of a loaded RevitLinkType. -or- This RevitLinkInstance is not an instance of a top-level RevitLinkType. -or- The operation is not permitted because the element is pinned. |

The link must be loaded for Revit to find the location of the link's base point. This operation can only be performed on instances of top-level links.