Basic |
Returns an instance of BasicFileInfo filled with basic information about a Revit file located at the given file-path
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- file String
- The full path to the file to be queried, including project (.rvt) and family (.rfa) files.
Return Value
BasicFileInfoIf successful, basic file data.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
FileArgumentNotFoundException | The file doesn't exist. |
InvalidOperationException | The file is a newer format file where the structure of the BasicFileInfo storage has changed, or the file is saved in very old version of Revit without basic file data. |