PipeFittingAndAccessoryData Class


Pipe Fitting And Accessory Data Class

The input data used by external servers for calculation of the pipe fitting and pipe accessory coefficient.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Plumbing PipeFittingAndAccessoryData

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PipeFittingAndAccessoryData : IDisposable

The PipeFittingAndAccessoryData type exposes the following members.

Properties
Name Description
Public property BehaviorType The behavior type of the pipe fitting or pipe accessory.
Public property FluidDensity The fluid density of the pipe fitting or pipe accessory, Units: (kg/ft³).
Public property FluidViscosity The fluid dynamic viscosity of the pipe fitting or pipe accessory, Units: (kg/(ft·s)).
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Origin The origin position of the pipe fitting or pipe accessory.
Public property PartType The part type of the pipe fitting or pipe accessory.
Public property ServerGUID The GUID of the pipe fitting or pipe accessory.
Public property SystemClassification The system classification of the pipe fitting or pipe accessory.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the PipeFittingAndAccessoryData
Public method GetAllConnectorData Gets the connector data of the pipe fitting or pipe accessory.
Public method GetEntity Returns an Entity of the Schema of the serverGUID.
Public method GetFamilyInstanceId Gets the Id of the fiting or accessory instance
Top
Remarks
A FamilyInstance is the input data for the calculation, and the result is coefficient for each connector.
See Also