Part |
Create a single merged part which represents the Parts specified by partsToMerge.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static PartMaker CreateMergedPart(
Document document,
ICollection<ElementId> partIds
)
Parameters
- document Document
- The document.
- partIds ICollection ElementId
- The elements that the merged part will be created from.
Return Value
PartMakerThe newly created PartMaker. if no parts are merged.

Exception | Condition |
---|---|
ArgumentException | One or more element ids was not suitable for merging with the others. Specified elements should all be Parts, report the same material, creation and demolition phases, and have contiguous geometry. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |