View Get |
Identifies if the filter is enabled in this view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- filterElementId ElementId
- The ElementId of the filter.
Return Value
BooleanTrue if the specified filter is enabled in this view, false otherwise.

Exception | Condition |
---|---|
ArgumentException | Filter is not applied to the view. -or- ElementId is not associated with a FilterElement. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes. |

Several filters can be applied to a view in a certain order. This enable/disable flag allows one to quickly turn on/off the action of a particular filter in this view (without removing the filter from the set of applied filters and losing the corresponding overrides). By default, all the filters applied to a view are enabled.