Document New |
Creates a new Area BoundaryConditions element on a reference.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public BoundaryConditions NewAreaBoundaryConditions(
Reference reference,
TranslationRotationValue X_Translation,
double X_TranslationSpringModulus,
TranslationRotationValue Y_Translation,
double Y_TranslationSpringModulus,
TranslationRotationValue Z_Translation,
double Z_TranslationSpringModulus
)
Parameters
- reference Reference
- The Geometry reference obtained from a Wall, Slab or Slab Foundation.
- X_Translation TranslationRotationValue
- A value indicating the X axis translation option.
- X_TranslationSpringModulus Double
- Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
- Y_Translation TranslationRotationValue
- A value indicating the Y axis translation option.
- Y_TranslationSpringModulus Double
- Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
- Z_Translation TranslationRotationValue
- A value indicating the Z axis translation option.
- Z_TranslationSpringModulus Double
- Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".
Return Value
BoundaryConditionsIf successful, NewAreaBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 2 - "Area". is returned if the operation fails.

This method will only function with the Autodesk Revit Structure application.

bool CreateAreaConditionWithReference(AnalyticalPanel wall, Autodesk.Revit.Creation.Document docCreation)
{
// Get the Geometry reference to the wall
Reference profileReference = null;
if (null == wall)
{
return false; // the profile reference can't be retrieved.
}
// loop through the curves of the wall and get the first one as a reference
foreach (Curve curve in wall.GetOuterContour())
{
AnalyticalModelSelector selector = new AnalyticalModelSelector(curve);
profileReference = wall.GetReference(selector);
if (null != profileReference)
{
break;
}
}
BoundaryConditions condition = null;
// Create the Area Boundary Conditions if we have a profileReference
if (null != profileReference)
{
// Create Area Boundary Conditions with profile reference.
condition = docCreation.NewAreaBoundaryConditions(profileReference, TranslationRotationValue.Fixed, 0,
TranslationRotationValue.Fixed, 0,
TranslationRotationValue.Fixed, 0);
}
return (null != condition);
}